OpenGL ES GL11

Hy ,
I’ve tested my app one some devices. On the HTC Desire, some LG device and on a third device. And there I get my problem. This device works on Android 2.2 but don’t support OpenGL 1.1?
I think that this must be a hardware problem, but I’m not sure. Does anyone know a solution, or does anyone had the same problem?

Greetings,
D